Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't see any charts at all
I really can't make heads or tails of this software. I was sold in about two minutes a few years ago when a club member made a presentation about SkyTools. It looked so amazing that I had to have it, and we could even get a discount with a group buy. I was 'all in', so to speak. I had been happily using Megastar for years with no issues, but SkyTools just looked amazing and I wanted to try it.

After looking at the demos online, I am still really impressed how anyone could be this brilliant or have enough time in one lifetime to create this software.

But, all I can manage to do, so far, is to bring up a list of, say, open clusters, but if I try to view the interactive atlas, naked eye sky, etc. for one of them, I just get a more or less blank screen with no star chart. When I click on some things to try to bring up the star chart, a window comes up telling me that SkyTools stopped working and I have to close it. Then I start the software again to try something else to get it to work...with no success.

There are many other things that don't work, but that one is the key feature for me - the interactive sky. Another issue is that double stars don't even give me a list (not to mention not being able to see them on the interactive sky - I can't even get the software to display a list). I also can't get a list of, say, all the Bayer stars or Flamsteed stars in a constellation, and most other features I could name simply don't work.

I can't imagine what is causing these issues. I'm using a Microsoft SurfacePro 3 and Win10. I don't have problems in general with this machine. Any clues what might be going wrong? Thank you for your help.  -Jason
I assume this is a fully patched system running Windows 10? I also have the same combination and it works fine. I had to disable the scaling display settings for high DPI systems in the shortcut but otherwise have no issues. I assume you have tried the reinstall option because it sounds like something is corrupted in your ST3 install.


Clearly something is very wrong. How long have you been using SkyTools? Had these features worked previously?

Also, in order to help I need to know if this is the download version or on media, and what edition it is..

As Owen suggests, try uninstalling via add/remove programs. Then reinstall.

Let me know if that doesn't help.
Clear skies,
Head Dude at Skyhound
SkyTools is even better than you were told by your club members.  But it is somewhat of a serious application and doesn’t spoon-feed the new user.  The more you work with it, the more amazing it becomes.

SkyTools 3 runs pretty well on a SurfacePro. I do it.  The small format of the Surface machine combined with the hand gestures of the machine make it harder to learn Skytools operations.  SkyTools 3 was created when computers were just emerging from the Stone Age, figuratively speaking.

If you are fortunate to have an older desktop or laptop running Windows 7 or earlier you’ll have a much easier time to learn how SkyTools works. I would install SkyTools the older machine and learn its features there.

Display problems with touch screens, mouse pads:  First annoying cause is the Mouse Zoom feature. The slightest unintended drag on the machine and you are zoomed to infinity.  To solve it, go to <SkyTools Preferences> icon in the Nightly Planner, select the <Preferences> tab, and check the box labeled <Disable mouse zoom>

In order for the Interactive Atlas and Eyepiece Views to display properly on the SurfacePro you must run SkyTools 3 with some application compatibility modifications.  

Here are settings that work for me:
1. Navigate to the location of <skytools.exe>, Right on it click for a dropdown menu, select <Properties>, select <Compatibility> tab. In the dialog box, check the "Override dpi scaling for high resolution display" box
2. Change the Surface Pro display settings in the Windows 10 application.  <Settings> <System> <Display> <Change size of text, apps, etc>, Select 125%
Also <Settings> <System> <Display> <Resolution>, Select 1440 x 900

Don’t give up.  You’ll be rewarded for perseverance.

Forum Jump:

Users browsing this thread: 1 Guest(s)