Skyhound Forums
Scope Connection Problems - Printable Version

+- Skyhound Forums (
+-- Forum: SkyTools Support (
+--- Forum: SkyTools 4 Support (
+--- Thread: Scope Connection Problems (/showthread.php?tid=444)

Pages: 1 2

RE: Scope Connection Problems - Nemesis@3319 - 2019-01-08


To date ASCOM people feel the problem lies elsewhere and not with ASCOM devices or drivers. We have used ASCOM's trace options and can find no problems.I have used the ASCOM simulator with ST4 and ST4 works just fine. I have one last thing to try and will do so tomorrow. I have another laptop PC that I keep in reserve. I am a present setting it up to replace the Acer laptop that has been the work horse in the observatory for almost 6 years. This will help me, on a systems level, determine if the Acer registers have been corrupted to a point that they may be causing this problem. I ran System mechanic on the Acer yesterday and it got a "GOOD" rating. So it still might be that ST4 is going to a register call that is no longer viable but still there. We'll see. Let you know results.

Himesa Obs

RE: Scope Connection Problems - theskyhound - 2019-01-08

Hi Bob,

Ok, please keep me apprised.

RE: Scope Connection Problems - Nemesis@3319 - 2019-01-09

(2019-01-06, 09:32 PM)theskyhound Wrote: Bob, please do not give up. This problem needs to be resolved, if not for you, then for the next person who runs into it.

Please contact the developers of the software that is generating the error message (ASCOM) and ask them about the message. Tell them what mount you use. This stuff is complicated. If they need to talk to me, please have them contact me.

Problem solved. SkyTools 4 now works with original Acer computer. The corruption was evidently in the USD to RS232 driver that went to the scope from the computer. Why SkyTools 3 did nor see it and SkyTools 4 did; well I simply can't explain that. Your program works ok it's not in your software. Sorry about the hassle over this should have thought of that earlier.

RE: Scope Connection Problems - theskyhound - 2019-01-09

Great news Bob!

Clear skies,

RE: Scope Connection Problems - Nemesis@3319 - 2019-01-09


After what has occurred on this problem I owe you a complete history of how I found the actual problem.

What happened was a lucky accident. I tried a HP laptop I keep in reserve in order to see if the problem was my Acer laptop. This meant that I completely break down my observatory setup and remove the Acer and use the HP laptop. It made no difference and SkyTools 4 would still not access the LX200GPS scope. I removed the HP laptop and reinstalled the Acer laptop. When the Acer came back online it attempted to  reacquaint itself with the US Converter's USB to serial Adapter (Ultimate) and Windows 7 went to the internet to find the latest FTDI drivers and reloaded them into the adapter. After completing hub and other cable hookups I tested the system and voilà SkyTools 4 now connected to the scope - go figure that one. So I checked the disk for the USB to serial adapters driver's dates and found that windows has loaded a much newer version of the drivers for the FT232RL processor in this USB to serial adapter. Either there was some low level corruption of the processor's original driver or the updated drivers that were downloaded had fixed a problem that somehow SkyTools 4 ran into. So the problem was never SkyTools 4 software or ASCOM software but USB to Serial Adapter software/drivers.

In conclusion, the US Converter USB to serial adapters use the FT232RL processor that functions like a mini computer with their own unique operating system but for a specific function, that of USB to serial conversion.  You might want to consider a cautionary note to SkyTools 4 users that use this type of USB to serial adapter (based on the FTDI Chip) be sure that they have the latest driver/software.
Bob Y
Himesa Obs   

RE: Scope Connection Problems - theskyhound - 2019-01-09

Thank you, Bob! I am so glad that you found the problem and are up and running, and I am sure that others are going to be interested in this result.

I just now came across another problem that was related to the USB to serial adapter. It had been reported last year, but I assumed it to be a one-off. As in your case, the connection worked for other software, but not SkyTools, which is very difficult to explain. But there you have it. From now on when someone has a connection problem I will be sure to mention this sort of thing as a possible cause.