Skyhound Forums
Having Trouble Inserting Elements - Printable Version

+- Skyhound Forums (
+-- Forum: General & Visual Observing (
+--- Forum: Observing Close Approaching Asteroids (
+--- Thread: Having Trouble Inserting Elements (/showthread.php?tid=1699)

Having Trouble Inserting Elements - bigmasterdrago - 2020-06-10

Downloaded MPC NEA Today but cannot find elements for 2020 LF. Nor do I know how to get them in if I force Horizons to make them for me. Bit of help please.

RE: Having Trouble Inserting Elements - theskyhound - 2020-06-10


The MPC has been a mess lately. There are two ways to go:

Download a Single Minor Planet

1. Open the Minor Planet Database
2. Select Download/Import Data
3. Click on Get single minor planet from the MPC

That seems to work, but I can't vouch for when they last updated the elements

Paste the Orbit from HORIZONS:

1. Open the Minor Planet Database
2. Click on Enter New Minor Planet
3. Copy and paste the elements from HORIZONS

You will have to enter the designations by hand, since HORIZONS only includes the orbit data in the element format.

RE: Having Trouble Inserting Elements - bigmasterdrago - 2020-06-11

Part of the problem is that I don't know which terms mean what on the Horizon page. In the mean anomaly tab there is an E+2 in the figure. It may be that means to move the decimal over to the right 2 times. For E-1 that would be to the left 1 decimal place. I just do not know. Not sure what the time reference is. When I do the entries and click OK, I get the hourglass for a long time, maybe 30 seconds. Then it will find it in a search. I'm clearly doing something wrong due to the fact that a Horizons ephemeris is nowhere close to the one generated in ST4. I've included images of both ephemerides and the elements I got from Horizons. I also have shown what ST4 has done to the elements that I inserted from the Horizon elements screen. Very much different. Why?

[Image: sOZNLim.jpg]

[Image: f6y5aMh.jpg]

[Image: n0FW0so.jpg]

RE: Having Trouble Inserting Elements - theskyhound - 2020-06-11

What I meant was to copy the entire set of elements, rather than one at a time. I think I explained how to do this on another thread.

Set the Ephemeris Type in HORIZONS to Orbital Elements. Then select and copy a set of elements like this:

2459011.500000000 = A.D. 2020-Jun-11 00:00:00.0000 TDB
EC= 3.972337854922277E-01 QR= 5.250546342070660E-01 IN= 5.908882245651601E+00
OM= 3.580869459619107E+02 W = 3.097681379094471E+02 Tp= 2459000.254502346274
N = 1.212329526549022E+00 MA= 1.363324884649077E+01 TA= 3.333762766573265E+01
A = 8.710750894288811E-01 AD= 1.217095544650696E+00 PR= 2.969489665279078E+02

Then click Paste on the dialog in SkyTools. You will have to fill in the Magnitude Parameters (from elsewhere on the HORIZONS page) and the designation

RE: Having Trouble Inserting Elements - bigmasterdrago - 2020-06-11

Thanks. I been getting elements from either JPL or Horizons. I manually entered them in ST4. When I go back in to attempt to edit them, the numbers, especially the dates, are way different than I entered them. There was some magnitude discrepancy on 2020 LF but it is only up in daylight so doesn't really matter.

I get "orbital element format not recognized" as I did the last time I tried that suggestion a few months back. This is when I click paste in the edit Minor Planet -- Osculating Elements when right clicking the date under that asteroid.

[Image: gtTowfw.jpg]

RE: Having Trouble Inserting Elements - theskyhound - 2020-06-11

The procedure I outlined should work a lot better.

You have to enter the dates in the proper formats. The Help button on the New/Edit dialog has some more info. If you are entering a JD, you need to put JD in front, like in the picture. So like "JD 2459011.5" or use the standard SkyTools date entry format, like "2020 June 11"

But if you are entered the Mean Anomly you don't enter T.

The epoch of osculation is entered just like in the picture.

RE: Having Trouble Inserting Elements - bigmasterdrago - 2020-06-11

Does this look right? All done by individual copy and paste. Will not work when doing a full copy and paste of all lines like you suggested. Never has for me. It's what I entered a bit earlier today but it looks changed to a different date later / see post #3.

[Image: N9cXbLe.jpg]

RE: Having Trouble Inserting Elements - theskyhound - 2020-06-11


The paste is working for me, but maybe there was a minor change in their format and I fixed it. The update is supposed to be ready now, but I've gone down a rabbit hole on a bug in the Scheduler. Hopefully soon.

Your numbers look good.