Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SkyTools3 has stopped opening properly
Yesterday my SkyTools3 Pro developed a glitch in that while it apparently opened, briefly showed its opening splash screen and displayed its icon in the task bar of my Win10 laptop it did not actually display on screen. Hovering the mouse over the taskbar icon showed a thumbnail image of the SkyTools screen but that contained no detail being simply all white On right clicking the icon I got the usual small menu offering to close the application and on selecting that I saw the usual small SkyTools dialog saying that it was some time since the last backup but offering to close anyway. On selecting to close, the taskbar icon was removed.

I have the installation CDs so I tried uninstalling and then reinstalling SkyTools3 but I still have the problem. My guess is that one or other of the SkyTools support files has become corrupted and needs to be removed or amended.

Version uninstalled : 3.2j R2 Pro Edition
Operating system : Windows 10

Can you please advise?


I have just had a similar problem with the ST4 beta. I manage to open the window in full screen by hovering over the icon on the task bar and then right clicking the little preview window that pops up. Here you can select 'Maximize' and in my case the window comes up. Once it's maximized don't use the 'Restore' button to make it smaller but drag the window from full screen down and it will become normal size again. After I did this all was well again.

Hope this helps,


Attached Files Thumbnail(s)
Assuming that hasn't resolved your issue, find your SkyTools 3 folder in your Documents and delete the file called "dds.bin." Then restart. If it does start, please be sure to update immediately! You could run into trouble if you use the original version with your latest files.
Clear skies,

SkyTools Developer
Mike / Greg Thanks for your replies.

 Mike : Unfortunately the only three right-click menu options were :
SkyTools3 – selecting this did nothing
Pin to taskbar – not wanted
Close – only remaining choice

 Greg : Yes deleting the dds.bin file worked. I've downloaded and installed the latest version 3.2k and all is good now. Thanks again.


Forum Jump:

Users browsing this thread: 1 Guest(s)